package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m),\s*`)
var str = `SELECT col1, col2, col3
FROM yourTable
ORDER BY col1;`
var substitution = ",\n"
fmt.Println(re.ReplaceAllString(str, substitution))
}