// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m),\s*").unwrap();
let string = "SELECT col1, col2, col3
FROM yourTable
ORDER BY col1;";
let substitution = ",\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}