$re = '/(?<!\bor) (?!or\b)/';
$str = 'You may organize to find or seek a neighbor or a pastor in a harbor or orchard.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);