using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(vue? d[ée]gag[ée]|vue? (d'?)?exception([a-z]+)?|vue? panoramique|vue? 360|sans vis [aà] vis)";
string input = @"avec vue dégagée
avec vue degagee
superbe vue dégagée
une belle vue dégagée
bénéficient d'une vue dégagée
terrasse offrant une vue dégagée
terrasse privative avec vue dégagée
terrasses avec vue dégagée
bureaux avec vue dégagée
bénéficie en façade d'une vue dégagée
surface bénéficie une vue dégagée
vue dégagée et sans vis à vis
rdc lumineux sans vis à vis
local sans vis a vis
avec une vue d'exception
avec une vue dexception
vue exceptionnelle
offrent une vue panoramique
lumineux vue panoramique
bénéficie d’une vue panoramique
dispose d'une vue panoramique
offre une vu panoramique
rooftop paysagé avec vue panoramique
vue 360° en rooftop";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}