use strict;
my $str = 'avec vue dégagée
avec vue degagee
superbe vue dégagée
une belle vue dégagée
bénéficient d\'une vue dégagée
terrasse offrant une vue dégagée
terrasse privative avec vue dégagée
terrasses avec vue dégagée
bureaux avec vue dégagée
bénéficie en façade d\'une vue dégagée
surface bénéficie une vue dégagée
vue dégagée et sans vis à vis
rdc lumineux sans vis à vis
local sans vis a vis
avec une vue d\'exception
avec une vue dexception
vue exceptionnelle
offrent une vue panoramique
lumineux vue panoramique
bénéficie d’une vue panoramique
dispose d\'une vue panoramique
offre une vu panoramique
rooftop paysagé avec vue panoramique
vue 360° en rooftop';
my $regex = qr/(vue? d[ée]gag[ée]|vue? (d'?)?exception([a-z]+)?|vue? panoramique|vue? 360|sans vis [aà] vis)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}