using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<.*?style=.*?)(\s*height.*?;)(.*?>)";
string input = @"<img src=""http://hello-world/img/a1.jpg"" style=""width: 800px; height: 600px; float:right;"">
<img src=""http://hello-world/img/a1.jpg"" style=""width: 800px; height: 60%; float:right;"">
<div style=""height:50px; width:10px;""></div>
<img src=""http://hello-world/img/a1.jpg"" style=""width: 800px; height: 5em; float:right;"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}