$re = '/(\| 40716 \| MESSAGE \| MQTT Server Device \| Einstellungen gespeichert)|(\| CUSTOM \| Receiver video info \|)/m';
$str = '06.01.2024 00:00:37 | 40716 | MESSAGE | MQTT Server Device | Einstellungen gespeichert';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);