using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"lettre/(?!somth\?other)[^""]*""";
string input = @"lettre/abc""
lettre/somth?other""
lettre/acc""
lettre/edf""de
lettre/nhy""
lettre/somth?other""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}