re = /lettre\/(?!somth\?other)[^"]*"/m
str = 'lettre/abc"
lettre/somth?other"
lettre/acc"
lettre/edf"de
lettre/nhy"
lettre/somth?other"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end