$re = '/ ^P
(?=\w*\d)
(?:(?<years>\d+)Y|Y)?
(?:(?<month>\d+)M|M)?
(?:(?<days>\d+)D|D)?
(?:
T
(?:(?<hours>\d+)H|H)?
(?:(?<minutes>\d+)M|M)?
(?:
(?<seconds>
\d+
(?:
\.
\d{1,2}
)?
)S
|
S
)?
)?$/x';
$str = 'P1Y3M2DT3H3.12S';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);