package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:http[s]:\/\/)stackoverflow.com.*`)
var str = `https://stackoverflow.com/questions/47637005/handmade-estimator-modifies-parameters-in-init/47637293?noredirect=1#comment82268544_47637293`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}