$re = '/(?=.*[}{,.^?~=+\-_\/*\-+.\|])(?=.*[a-zA-Z])(?=.*[0-9]).{8,}/m';
$str = '12345678
ASDAS^^?
ASD1ASDA
WWEA^^1
A1234567
123^8542
A{123456
A^^BCVSD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);