import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(.{1,40})([\\s-]|$))|(.{1,40})";
final String string = "Produktbezeichnung: Sub TWU 3-0123 (1x230 V, 50 Hz)\n"
+ "Qmax = 7\n"
+ "sadas dfdsfs dfvsdvdfdsfaafdsfsdfsfsdffsdff\n"
+ "asdfdgdgdfggggggggggggggggggggggggggggggg";
final String subst = "$1$3|";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}