import Foundation
let pattern = #"(?<Date>\d{4}-\d{2}-\d{2}\s+\d{2}:\d{2}:\d{2})\s+(?<Type>\w+)\s\((?<Thread>[^\r\n]*)\)\s\[(?<Component>[^\r\n]*)]\s+(?<Message>[^\r\n]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
2018-11-08 19:36:30 DEBUG (MainThread)
[homeassistant.components.websocket_api.http.connection.22795306331048]
Sending {'id': 548, 'type': 'event', 'event': {'event_type': 'state_changed', 'data': {'entity_id': 'sun.sun', 'old_state': <state sun.sun=below_horizon; next_dawn=2018-11-09T06:54:59+00:00,next_dusk=2018-11-09T16:58:42+00:00,next_midnight=2018-11-08T23:56:54+00:00,next_noon=2018-11-09T11:56:50+00:00,next_rising=2018-11-09T07:35:52+00:00,next_setting=2018-11-09T16:17:49+00:00, elevation=-27.7, azimuth=280.88, friendly_name=Sun @ 2018-11-08T16:19:48.008546+00:00>, 'new_state': <state sun.sun=below_horizon; next_dawn=2018-11-09T06:54:59+00:00,next_dusk=2018-11-09T16:58:42+00:00,next_midnight=2018-11-08T23:56:54+00:00,next_noon=2018-11-09T11:56:50+00:00,next_rising=2018-11-09T07:35:52+00:00,next_setting=2018-11-09T16:17:49+00:00, elevation=-27.84, azimuth=281.1, friendly_name=Sun @ 2018-11-08T16:19:48.008546+00:00>}, 'origin': 'LOCAL', 'time_fired': datetime.datetime(2018, 11, 8, 19, 36, 30, 11522, tzinfo=<UTC>), 'context': {'id': '0ac682ff98424a2d970bc2f0fbd1683f','user_id': None}}}2018-11-08 19:36:30 DEBUG (Thread-6) [pychromecast.socket_client] connection listener: 14bbb1927b70 (CastStatusListener)
2018-11-08 19:36:30 DEBUG (Thread-6)
[homeassistant.components.media_player.cast] Received cast device connection status: CONNECTING
2018-11-08 19:36:31 DEBUG (InfluxDB) [homeassistant.components.influxdb]
Wrote 1 events
2018-11-08 19:36:32 DEBUG (SyncWorker_29) [mpd.base] Calling MPD status()
2018-11-08 19:36:32 DEBUG (SyncWorker_29) [mpd.base] Calling MPD currentsong()
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)