#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\bAPV\b"
Local $sString = ""APV", "SAPV, APV", "SCA, FFMM, APV", "SCA, SAPV", "FFMM, APV", "FFMM", "SCA, SAPV, APV", "SCA, SAPV, FFMM, FFAC", "SCA, FFMM", "SAPV", "SCA", "SCA, APV", "SAPV, FFMM", "SCA, SAPV, FFMM, APV", "SAPV, FFMM, APV""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")