using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+\s*|\s*,(?:\s*(?:Dr[sa]?|Prof|M\.Ag|M[EM])\.?)+$";
string substitution = @"";
string input = @"Dr. RICHARD, MM
Dr. BOBBY Richard Klaus, MM
Richard, MM";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}