re = /\.?([^.]*Bylaw.+?(\.|$))/i
str = 'hello the world . a Bylaw to provide for the government and management of the Water Works System in the City and th
e collection of Rents, Rates, and charges for water. blah blah blah.
A bylaw to do something'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end