package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\s+)(flavorDimensions)(?:\s)(?:\")(\S+)(?:\")`)
var str = ` flavorDimensions "mode"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}