#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!.*\..*\.)(?!.*_.*_)[A-Za-z0-9_.])*$"
Local $sString = "abcd.efg" & @CRLF & _
"abcd.efg." & @CRLF & _
"abcd_efg" & @CRLF & _
"abcd_efg_" & @CRLF & _
"123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")