import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?!.*\\..*\\.)(?!.*_.*_)[A-Za-z0-9_.])*$";
final String string = "abcd.efg\n"
+ "abcd.efg.\n"
+ "abcd_efg\n"
+ "abcd_efg_\n"
+ "123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}