re = /^((?!.*\..*\.)(?!.*_.*_)[A-Za-z0-9_.])*$/m
str = 'abcd.efg
abcd.efg.
abcd_efg
abcd_efg_
123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end