using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^name: .*(?:\n(?!name: ).*)*";
string input = @"name: marvin
attribute: one
day: monday
dayalt: test << this is a field that can sometimes show up
name: judy
attribute: two
day: tuesday
name: dot
attribute: three
day: wednesday";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}