package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<a[\S\s]+?<\/a>(*SKIP)(*FAIL)|\bas\b`)
var str = `class
bass
taste
as
as in there are
<a href="as.php">a link as a nother thing</a>
as in none link`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}