const regex = /<a[\S\s]+?<\/a>(*SKIP)(*FAIL)|\bas\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<a[\\S\\s]+?<\\\/a>(*SKIP)(*FAIL)|\\bas\\b', 'gm')
const str = `class
bass
taste
as
as in there are
<a href="as.php">a link as a nother thing</a>
as in none link`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}