package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.0*$|(\.\d*[1-9])0+$`)
var str = `0
00
01
1.0
1.00
1.001100
1.101110000
1234870.98762341
1230009100
0.0012234
0.1200234
0.000001231
0.10001
NaN`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}