$re = '/([^\n]+?\.cpp)\((\d+),(\d+)\) : error: ([^\n]+)/';
$str = 'C:\\Users\\J\\Documents\\project\\code\\win32_jesse.cpp(772,70) : error: expected \';\' after expression
AssetClock += Win32GetSecondsElapsed(LastCounter, EndCounter)
^
;
1 error generated.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);