import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-z0-9\\.\\-]+@[A-z0-9\\.\\-]+\\.[A-z0-9]{2,3}$";
final String string = "muratsanturkey2001@hotmail.com\n"
+ "muratsab4@gmail.com\n"
+ "murat.san@x2.gov\n"
+ "Murat-San.Hero@outlook.x2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}