import Foundation
let pattern = ##"([A-Za-z0-9!#-'*+\-/=?^_`{-~\xA0-\x{10FFFF}]+(?:\.[A-Za-z0-9!#-'*+\-/=?^_`{-~\xA0-\x{10FFFF}])|(?:[ !#-\[\]-~\xA0-\x{10FFFF}]|\\[ -~])*)@((?:[A-Za-z0-9](?:[A-Za-z0-9\-]*[A-Za-z0-9])?|[\x00-\x{10FFFF}]*[\x80-\x{10FFFF}]+[\x00-\x{10FFFF}]*)(?:\.(?:[A-Za-z0-9](?:[A-Za-z0-9\-]*[A-Za-z0-9])?|[\x00-\x{10FFFF}]*[\x80-\x{10FFFF}]+[\x00-\x{10FFFF}]*))*)"##
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"email@email.co.za"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}