package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((\w+)\s*(\W*(\w+)*\W*)?)*`)
var str = `echo "Hello"
shed --version`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}