package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[A-Z]{3}-[0-9]{4}((?:\s[\w-]+)*)`)
var str = `|Placa:AVX-4300 Fiat Uno |
|Placa:AVX-4300 Fiat Uno Modelo 2010|
|Placa:AVX-4300 Fiat Uno Modelo 2010 Ano 2011|
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}