// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[A-Z]{3}-[0-9]{4}((?:\s[\w-]+)*)").unwrap();
let string = "|Placa:AVX-4300 Fiat Uno |
|Placa:AVX-4300 Fiat Uno Modelo 2010|
|Placa:AVX-4300 Fiat Uno Modelo 2010 Ano 2011|
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}