re = /^(?=.{0,20}$)(?:[a-zA-Z0-9]+(?:-[a-zA-Z0-9]+)?)?$/m
str = '12345abc90
12345abc9012345abc90
12345abc90-12345abc9
12345abc90-12345abc90'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end