using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.+?)((?:\s\w+\.){0,}\[{0,}(`){0,}Тип заканчивания\3{0,}\]{0,})(.+)$";
string substitution = @"$1$2$4 GROUP BY $2";
string input = @"SELECT `Тип заканчивания`,
`Дата ввода` FROM [DeleteMe8$A1:B21]
";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}