import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(.+?)((?:\\s\\w+\\.){0,}\\[{0,}(`){0,}Тип заканчивания\\3{0,}\\]{0,})(.+)$";
final String string = "SELECT `Тип заканчивания`, \n"
+ "`Дата ввода` FROM [DeleteMe8$A1:B21]\n";
final String subst = "$1$2$4 GROUP BY $2";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}