use strict;
my $str = 'SELECT `Тип заканчивания`,
`Дата ввода` FROM [DeleteMe8$A1:B21]
';
my $regex = qr/^(.+?)((?:\s\w+\.){0,}\[{0,}(`){0,}Тип заканчивания\3{0,}\]{0,})(.+)$/sp;
my $subst = '$1$2$4 GROUP BY $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";