import Foundation
let pattern = #"Language:\s*(\w+)\s*Place:\s*HK"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Language: English
Place: Seattle
Segments: b,p,m,d,t
Language: Mandarin
Place: HK
Segments: n,i,o,h
Language: Cantonese
Place:HK
Segments:l,e,h,o
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)