$re = '/^[0-9]+(.*(Minutes|Seconds|Hours|Days))+$/m';
$str = '38 Seconds';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);