using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(?:(?:(?:var|let)[ \t]+)?([\w.\-]+)[ \t]*[:=]|[(!])[ \t]*)function(?:[ \t]+([\w.\-]+))?[ \t]*\([^)]*\)";
string input = @"!function(){}() // test1
!function test2(){}() // test2
(function(){})() // test3
(function test4(){})() // test4
test5 = function(){} // test5
test6 = function _test6(){} // test6
let test7 = function(){} // test7
let test8 = function _test8(){} // test8
var test9 = function(){} // test8
var test10 = function _test10(){} // test10
myfunc(function(){}) // test11
myfunc(function test12(){}) // test12
let myobj = {test13 : function(){}} // test13
let myobj = {test14 : function _test14(){}} // test14
var myobj = {test15 : function(){}} // test15
var myobj = {test16 : function _test16(){}} // test16
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}