// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:(?:(?:(?:var|let)[ \t]+)?([\w.\-]+)[ \t]*[:=]|[(!])[ \t]*)function(?:[ \t]+([\w.\-]+))?[ \t]*\([^)]*\)").unwrap();
let string = "!function(){}() // test1
!function test2(){}() // test2
(function(){})() // test3
(function test4(){})() // test4
test5 = function(){} // test5
test6 = function _test6(){} // test6
let test7 = function(){} // test7
let test8 = function _test8(){} // test8
var test9 = function(){} // test8
var test10 = function _test10(){} // test10
myfunc(function(){}) // test11
myfunc(function test12(){}) // test12
let myobj = {test13 : function(){}} // test13
let myobj = {test14 : function _test14(){}} // test14
var myobj = {test15 : function(){}} // test15
var myobj = {test16 : function _test16(){}} // test16
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}