package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\w+$`)
var str = `2131qweqweqw___`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}