#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[a-z0-9\.-_]+@[\w\d]+\.\w+"
Local $sString = "ivan@example.com" & @CRLF & _
"i.v.a.n.@example.com" & @CRLF & _
"_i_v_a_n_@example.com" & @CRLF & _
"ivan@perro.gato" & @CRLF & _
"ivan@perro.gato.com" & @CRLF & _
"ivan+@example.com" & @CRLF & _
"email@domain.com" & @CRLF & _
"firstname.lastname@domain.com" & @CRLF & _
"email@subdomain.domain.com" & @CRLF & _
"firstname+lastname@domain.com" & @CRLF & _
"email@123.123.123.123" & @CRLF & _
"email@[123.123.123.123]" & @CRLF & _
""email"@domain.com" & @CRLF & _
"1234567890@domain.com" & @CRLF & _
"email@domain-one.com" & @CRLF & _
"_______@domain.com" & @CRLF & _
"email@domain.name" & @CRLF & _
"email@domain.co.jp" & @CRLF & _
"firstname-lastname@domain.com" & @CRLF & _
"plainaddress" & @CRLF & _
"#@%^%#$@#$@#.com" & @CRLF & _
"@domain.com" & @CRLF & _
"Joe Smith <email@domain.com>" & @CRLF & _
"email.domain.com" & @CRLF & _
"email@domain@domain.com" & @CRLF & _
".email@domain.com" & @CRLF & _
"email.@domain.com" & @CRLF & _
"email..email@domain.com" & @CRLF & _
"あいうえお@domain.com" & @CRLF & _
"email@domain.com (Joe Smith)" & @CRLF & _
"email@domain" & @CRLF & _
"email@-domain.com" & @CRLF & _
"email@domain.web" & @CRLF & _
"email@111.222.333.44444" & @CRLF & _
"email@domain..com"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")