const regex = /[a-z0-9\.-_]+@[\w\d]+\.\w+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[a-z0-9\\.-_]+@[\\w\\d]+\\.\\w+', 'gm')
const str = `ivan@example.com
i.v.a.n.@example.com
_i_v_a_n_@example.com
ivan@perro.gato
ivan@perro.gato.com
ivan+@example.com
email@domain.com
firstname.lastname@domain.com
email@subdomain.domain.com
firstname+lastname@domain.com
email@123.123.123.123
email@[123.123.123.123]
"email"@domain.com
1234567890@domain.com
email@domain-one.com
_______@domain.com
email@domain.name
email@domain.co.jp
firstname-lastname@domain.com
plainaddress
#@%^%#\$@#\$@#.com
@domain.com
Joe Smith <email@domain.com>
email.domain.com
email@domain@domain.com
.email@domain.com
email.@domain.com
email..email@domain.com
あいうえお@domain.com
email@domain.com (Joe Smith)
email@domain
email@-domain.com
email@domain.web
email@111.222.333.44444
email@domain..com`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}