// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:\w{2,}\.[^\S\n]+)+|[^\w\s]+").unwrap();
let string = "DR. Tida.
prof. Sina.
DR. prof. Tida.";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}