$re = '/[A-Z]{2,}\d+(*SKIP)(*FAIL)|[A-Z](\d+)/m';
$str = 'A12B8Y9CC10
V5C8I17
KK18II9
I8VV22ZZ4S9U2
A18Z12I';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);