import re
regex = re.compile(r"[A-Z]{2,}\d+(*SKIP)(*FAIL)|[A-Z](\d+)", flags=re.MULTILINE)
test_str = ("A12B8Y9CC10\n"
"V5C8I17\n"
"KK18II9\n"
"I8VV22ZZ4S9U2\n"
"A18Z12I")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")