// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Z]{2,}\d+(*SKIP)(*FAIL)|[A-Z](\d+)").unwrap();
let string = "A12B8Y9CC10
V5C8I17
KK18II9
I8VV22ZZ4S9U2
A18Z12I";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}