package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)assignments$`)
var str = `1.) https://beta-qa.pearson.com/iie-api/courses/5daa3022e4b0ef7dce37acec/assignments
2.) https://beta-qa.pearson.com/iie-api/courses/5daa3022e4b0ef7dce37acec/assignments/984fa00d-d002-4826-80f4-76d1267e3aaa
3.) https://beta-qa.pearson.com/iie-api/courses/5daa3022e4b0ef7dce37acec/assignments/984fa00d-d002-4826-80f4-76d1267e3aaa/assignments`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}