$re = '/[^\p{Z}\p{L}.;:?!]/m';
$str = 'abcd 123 kjd ¤%/(" .?:!';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);