using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.{20}).*?(?=(?<ch>[@#$^]))(?<match>\k<ch>{6,}).*(?<=.{10})\k<match>.*";
string input = @"$$$$$$$$$$$$$$$$$$$$
aabb
th@@@@@@eemo@@@@@@ey
Cash$$$$$$Ca$$$$$$sh
validticketnomatch:(
$$$$$$$$$$##########
$$$$$$$$##$$$$$$$$$$";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}