re = /(?=.{20}).*?(?=(?<ch>[@#$^]))(?<match>\k<ch>{6,}).*(?<=.{10})\k<match>.*/m
str = '$$$$$$$$$$$$$$$$$$$$
aabb
th@@@@@@eemo@@@@@@ey
Cash$$$$$$Ca$$$$$$sh
validticketnomatch:(
$$$$$$$$$$##########
$$$$$$$$##$$$$$$$$$$'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end